A6 - Выполнение алгоритмов для исполнителей

1. Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 3 раз
Команда1
Сместиться на (3, 3)
Сместиться на (1, –2)
Конец
Сместиться на (–6, 9)
После выполнения этого алгоритма Чертёжник вернулся в исходную точку. Какую команду надо поставить вместо команды Команда1?
Сместиться на (2, 4)
Сместиться на (-6, 12)
Сместиться на (-2, -4)
Сместиться на (2, -10)
2. Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 3 раз
Сместиться на (1, 2)
Сместиться на (2, –1)
Сместиться на (2, 0)
конец
Какую команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?
Сместиться на (15, 3)
Сместиться на (-15, 3)
Сместиться на (15, -3)
Сместиться на (-15, -3)
3. Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 2 раз
Сместиться на (–3, –4)
Сместиться на (3, 3)
Сместиться на (1, –2)
Конец
Какую единственную команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?
Сместиться на (2, -6)
Сместиться на (-6, 2)
Сместиться на (6, -2)
Сместиться на (-2, 6)
4. Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 3 раз
Сместиться на (–2, –1)
Сместиться на (3, 2)
Сместиться на (2, 1)
Конец
Какую единственную команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?
Сместиться на (9, 6)
Сместиться на (–6, -9)
Сместиться на (6, 9)
Сместиться на (–9, -6)
5. Чертёжнику был дан для исполнения следующий алгоритм:
Повтори 3 раз
Сместиться на (1, 3)
Сместиться на (–2, –5)
конец
Сместиться на (4, 8)
Какую команду надо выполнить Чертёжнику, чтобы вернуться в исходную точку, из которой он начал движение?
Сместиться на (–1, 2)
Сместиться на (-1, -2)
Сместиться на (1, -2)
Сместиться на (-2, 1)
6. Черепашке был дан для исполнения следующий алгоритм:
  Повтори 12 [Направо 45 Вперёд 20 Направо 45]
Какая фигура появится на экране?
незамкнутая ломаная линия
правильный двенадцатиугольник
квадрат
правильный восьмиугольник
7. При выполнении какого из перечисленных ниже алгоритмов Черепаха нарисует на экране правильный треугольник?
Повтори 3 [Вперёд 50 Направо 20 Направо 25]
Повтори 3 [Вперёд 50 Направо 100 Направо 20]
Повтори 6 [Вперёд 50 Направо 10 Направо 20]
Повтори 6 [Вперёд 50 Направо 20 Направо 40]
8. При выполнении какого из перечисленных ниже алгоритмов Черепаха нарисует на экране правильный шестиугольник?
Повтори 6 [Вперёд 100 Направо 90]
Повтори 6 [Вперёд 100 Направо 9]
Повтори 6 [Вперёд 100 Направо 60 Направо 60]
Повтори 6 [Вперёд 100 Направо 20 Направо 40]
9. Черепашке был дан для исполнения следующий алгоритм:
  Повтори 180 [Вперёд 45 Направо 90]
Какая фигура появится на экране?
правильный 180-угольник
квадрат
правильный восьмиугольник
незамкнутая ломаная линия
10. Черепашке был дан для исполнения следующий алгоритм:
  Повтори 360 [Вперёд 30 Направо 60]
Какая фигура появится на экране?
правильный 360-угольник
правильный треугольник
правильный шестиугольник
незамкнутая ломаная линия