АлгЯзык: 40 - Циклы с условием

1. Чему будет равно значение переменной N после выполнения програмы:
  N:=7
нц пока N > 8
N:=N-1
кц
Ответ: 
2. Сколько раз будет выведено на экран слово 'Привет' после выполнения програмы:
  N:=7
нц пока N < 8
N:=N+1
вывод 'Привет', нс
кц
Ответ: 
3. Какое число будет выведено на экран в результате выполнения этого цикла?
  i:=5
вывод '9'
нц пока i<5
вывод i
i:=i+1
кц
Ответ: 
4. Чему будет равно значение переменной «a» после выполнения этого цикла?
  i:=4
a:=12
нц пока i<5
a:=a+i
i:=i+1
кц
Ответ: 
5. Чему будет равно значение переменной «a» после выполнения этого цикла?
  i:=3
a:=0
нц пока i<6
a:=a+i
i:=i+2
кц
Ответ: 
6. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 3 раза?
  i:=...
нц пока i<=4
вывод 'Привет!'
i:=i+1
кц
Ответ: 
7. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 4 раза?
  i:=...
нц пока i>=0
вывод 'Привет!'
i:=i-1
кц
Ответ: