АлгЯзык: 41 - Циклы с переменной

1. Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?
  a:=10
нц для i от 1 до 3
a:=a-1
кц
Ответ: 
2. Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?
  a:=10
нц для i от 0 до 4
a:=a-i
кц
Ответ: 
3. Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?
  a:=2
нц для i от 0 до 3
a:=a+i
кц
Ответ: 
4. Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?
  a:=4;
нц для i от 1 до 3
a:=a+a
кц
Ответ: 
5. Какое число будет выведено на экран после выполнения этого фрагмента программы?
  нц для i от 3 до 0 шаг -1
вывод i
кц
Ответ: 
6. Какое число будет выведено на экран после выполнения этого фрагмента программы?
  вывод 4
нц для i от 3 до 1 шаг -1
вывод 2*i
кц
Ответ: 
7. Какое число будет выведено на экран после выполнения этого фрагмента программы?
  вывод 1
нц для i от 4 до 7
вывод i
кц
Ответ: