16 - Выполнение алгоритмов для исполнителей

1. Черепашке был дан для исполнения следующий алгоритм:
  Повтори 12 [Направо 45 Вперёд 20 Направо 45]
Какая фигура появится на экране?
незамкнутая ломаная линия
правильный двенадцатиугольник
квадрат
правильный восьмиугольник
2. При выполнении какого из перечисленных ниже алгоритмов Черепаха нарисует на экране правильный треугольник?
Повтори 3 [Вперёд 50 Направо 20 Направо 25]
Повтори 3 [Вперёд 50 Направо 100 Направо 20]
Повтори 6 [Вперёд 50 Направо 10 Направо 20]
Повтори 6 [Вперёд 50 Направо 20 Направо 40]
3. При выполнении какого из перечисленных ниже алгоритмов Черепаха нарисует на экране правильный шестиугольник?
Повтори 6 [Вперёд 100 Направо 90]
Повтори 6 [Вперёд 100 Направо 9]
Повтори 6 [Вперёд 100 Направо 60 Направо 60]
Повтори 6 [Вперёд 100 Направо 20 Направо 40]
4. Черепашке был дан для исполнения следующий алгоритм:
  Повтори 180 [Вперёд 45 Направо 90]
Какая фигура появится на экране?
правильный 180-угольник
квадрат
правильный восьмиугольник
незамкнутая ломаная линия
5. Черепашке был дан для исполнения следующий алгоритм:
  Повтори 360 [Вперёд 30 Направо 60]
Какая фигура появится на экране?
правильный 360-угольник
правильный треугольник
правильный шестиугольник
незамкнутая ломаная линия
6. У исполнителя Калькулятор две команды:
  1. прибавь 2 
2. умножь на 2
Какое число получит этот исполнитель, если выполнит программу 122112 для начального числа 6?
Ответ: 
7. У исполнителя Калькулятор две команды:
  1. вычти 2 
2. умножь на 3
Какое число получит этот исполнитель, если выполнит программу 211221 для начального числа 5?
Ответ: 
8. У исполнителя Калькулятор две команды:
  1. вычти 3 
2. умножь на 2
Какое число получит этот исполнитель, если выполнит программу 121221 для начального числа 9?
Ответ: 
9. У исполнителя Калькулятор две команды:
  1. вычти 4 
2. умножь на 3
Какое число получит этот исполнитель, если выполнит программу 211211 для начального числа 6?
Ответ: