АлгЯзык: 23 - Циклы с условием

1. Чему будет равно значение переменной N после выполнения програмы:
  N := 8
нц пока N > 7
N := N - 1
кц
Ответ: 
2. Сколько раз будет выведено на экран слово "Привет" после выполнения програмы:
  N := 5
нц пока N < 10
N := N + 1
вывод "Привет", нс
кц
Ответ: 
3. Какое число будет выведено на экран в результате выполнения этого цикла?
  i:=7
вывод "9"
нц пока i<11
вывод i
i := i + 1
кц
Ответ: 
4. Чему будет равно значение переменной a после выполнения этого цикла?
  i := 2
a := 12
нц пока i<5
a := a + i
i := i + 1
кц
Ответ: 
5. Чему будет равно значение переменной a после выполнения этого цикла?
  i := 2
a := 0
нц пока i<4
a := a + i
i := i + 2
кц
Ответ: 
6. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?
  i := ...
нц пока i <= 2
вывод "Привет!"
i := i + 1
кц
Ответ: 
7. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?
  i := ...
нц пока i >= 6
вывод "Привет!"
i := i - 1
кц
Ответ: