АлгЯзык: 25 - Массивы

1. Отметьте все правильные утверждения о массивах в алгоритмическом языке.
элементы массива могут быть разных типов
все элементы массива должны быть одного типа
элементы в памяти расположены рядом
элементы могут быть расположены в памяти по одному
элементы всегда нумеруются с единицы
2. Отметьте все правильные объявления массива в алгоритмическом языке.
цел A[1:20]
целтаб A[1:20]
целтаб A[-8:10]
целтаб A[10:-8]
таб A[1:10]
3. Сколько байт в памяти занимает массив A, если на целое число отводится 4 байта?
  целтаб A[-3:2]
Ответ: 
4. Как называется число, которое указывает на конкретный элемент массива и записывается в квадратных скобках?
Ответ: 
5. Массив нужно заполнить именно так:
  X = [1 3 5 7 9 11]
Какой оператор надо поместить в тело цикла
  нц для k от 1 до 6
...
кц
X[k]:= k
X[k]:= 2*k
X[k]:= 2*k - 1
X[k]:= 2*k + 1
X[k]:= 2*(k - 1)
6. Массив нужно заполнить именно так:
  X = [12 9 6 3 0 -3]
Какой оператор надо поместить в тело цикла
  нц для k от 1 до 6 
...
кц
X[k]:= k
X[k]:= 14 - 2*k
X[k]:= 3*k - 15
X[k]:= 3*(k - 1) + 6
X[k]:= 15 - 3*k
7. Массив нужно заполнить именно так:
  X = [3 4 7 8 11 12]
Какой оператор надо поместить в тело цикла
  нц для k от 1 до 6 
...
кц
X[k]:= 3*k - mod(k, 2)
X[k]:= 2*k + mod(k, 2)
X[k]:= 2*k - mod(k, 2)
X[k]:= 2*k + div(k, 2)
X[k]:= 2*(k - 1)
8. Массив нужно заполнить именно так:
  X = [1 2 4 8 16 32]
Какой оператор надо поместить в тело цикла
  X[1]:= 1
нц для k от 2 до 6
...
кц
X[k]:= k
X[k]:= 2*k
X[k]:= X[k-1] + 1
X[k]:= 2*X[k-1]
X[k]:= 2*(X[k-1] - 1)
9. Массив заполнен числами:
  A = [3 5 2 1 4]
Какое число выведет на экран оператор
 вывод A[3]
Ответ: 
10. Массив
  X = [4 3 2 1 5]
обработан с помощью цикла
  нц для i от 1 до 5
X[i]:= X[i]+1
кц
Что выведен на экран оператор
  вывод X[3]
Ответ: 
11. Что надо написать вместо многоточия, чтобы вывести элементы массива X[1:N] в обратном порядке? В ответе не используйте пробелы.
  нц для k от 1 до N 
вывод ..., " "
Ответ: 
12. Какой оператор надо вставить вместо многоточия, чтобы вывести на экран все элементы массива A[1..N] с чётными номерами? В ответе не используйте пробелы.
  k := 2
нц пока k <= N
вывод A[k], " "
...
кц
Ответ: