АлгЯзык: 26 - Алгоритмы обработки массивов

1. Задан массив X[1:N]. Какой оператор надо поставить вместо многоточия, чтобы найти в переменной S сумму всех элементов массива? Вводите ответ без пробелов.
  S:= 0
нц для j от 1 до N
...
кц
Ответ: 
2. Задан массив X[1:N]. Какое условие надо поставить вместо многоточия, чтобы найти в переменной S сумму положительных элементов массива? Вводите ответ без пробелов.
  S:= 0
нц для k от 1 до N
если ...
то S:= S + X[k]
все
кц
Ответ: 
3. Задан массив X[1:N]. Какое условие надо поставить вместо многоточия, чтобы найти в переменной S сумму элементов массива, которые делятся на 5? Вводите ответ без пробелов.
  S:= 0
нц для k от 1 до N
если ...
то S:= S + X[k]
все
кц
Ответ: 
4. Задан массив X[1:N]. Какое условие надо поставить вместо многоточия, чтобы найти в переменной S сумму элементов массива, десятичная запись которых заканчивается на 4? Вводите ответ без пробелов.
  S:= 0
нц для k от 1 до N
если ...
то S:= S + X[k]
все
кц
Ответ: 
5. Задан массив X[1:N]. Какое условие надо поставить вместо многоточия, чтобы найти в переменной S количество чётных элементов массива? Вводите ответ без пробелов.
  S:= 0
нц для k от 1 до N
если ...
то S:= S + 1
все
кц
Ответ: 
6. Задан массив X[1:N]. Какое условие надо поставить вместо многоточия, чтобы найти в переменной S количество элементов массива, делящихся на 3? Вводите ответ без пробелов.
  S:= 0
нц для k от 1 до N
если ...
то S:= S + 1
все
кц
Ответ: 
7. Задан массив X[1:N]. Какое условие надо поставить вместо многоточия, чтобы найти в переменной S количество элементов массива, десятичная запись которых оканчивающется на 6? Вводите ответ без пробелов.
  S:= 0
нц для k от 1 до N
если ...
то S:= S + 1
все
кц
Ответ: 
8. Задан массив X[1:N]. Какое условие надо поставить вместо многоточия, чтобы найти минимальный элемент массива в переменной M? Вводите ответ без пробелов.
  M:= X[1]
нц для k от 2 до N
если ...
то M:= X[k]
все
кц
Ответ: 
9. Задан массив X[1:N]. Какой оператор надо поставить вместо многоточия, чтобы найти номер максимального элемента массива в переменной M? Вводите ответ без пробелов.
  M:= 1
нц для k от 2 до N
если X[k] > X[M]
то ...
все
кц
Ответ: