АлгЯзык: 26x - Обработка массивов (ОГЭ)

1. В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1] – количество голосов, поданных за первого исполнителя; Dat[2] – за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
  цел k, m
целтаб Dat[1:10]
Dat[1]:= 16; Dat[2]:= 20
Dat[3]:= 20; Dat[4]:= 41
Dat[5]:= 14; Dat[6]:= 21
Dat[7]:= 28; Dat[8]:= 12
Dat[9]:= 15; Dat[10]:= 35
m := 0
нц для k от 1 до 10
если Dat[k]>m то
m := Dat[k]
все
кц
вывод m
Ответ: 
2. В таблице Ves хранятся данные о весе в килограммах по группе учащихся спортивной школы (Ves[1] – вес первого учащегося, Ves[2] – вес второго учащегося и т. д.). Определите, что будет напечатано в результате выполнения следующего алгоритма.
  целтаб Ves[1:14]
цел i, n
Ves[1] := 25; Ves[2] := 21
Ves[3] := 23; Ves[4] := 28
Ves[5] := 30; Ves[6] := 25
Ves[7] := 31; Ves[8] := 28
Ves[9] := 25; Ves[10] := 28
Ves[11] := 30; Ves[12] := 27
Ves[13] := 26; Ves[14] := 24
n := 0
нц для i от 1 до 14
если Ves[i] > 26 то
n := n + 1
все
кц
вывод n
Ответ: 
3. Школьница делала лабораторную работу по физике, в ходе которой измерила 10 раз силу тока и записала показания амперметра в таблицу Tok (Tok[1] – результат первого измерения, Tok[2] – второго и т. д.). Определите, какое
число будет напечатано в результате работы следующей программы.
  цел k, m
целтаб Tok[1:10]
Tok[1] := 10; Tok[2] := 14
Tok[3] := 15; Tok[4] := 4
Tok[5] := 12; Tok[6] := 6
Tok[7] := 3; Tok[8] := 5
Tok[9] := 5; Tok[10] := 10
m := 0
нц для k от 1 до 10
если Tok[k] > 6 то
m := m + 2
все
кц
вывод m
Ответ: 
4. В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
  цел k, m
целтаб Dat[1:10]
Dat[1] := 12; Dat[2] := 15
Dat[3] := 17; Dat[4] := 15
Dat[5] := 14; Dat[6] := 12
Dat[7] := 10; Dat[8] := 13
Dat[9] := 14; Dat[10] := 15
m := 20
нц для k от 1 до 10
если Dat[k]< m то
m := Dat[k]
все
кц
вывод m
Ответ: 
5. Известная авиакомпания заносила данные о количестве утерянного багажа за год в таблицу Lose. Всего были занесены данные за последние 10 лет работы компании (Lose[1] – количество утерянного багажа за первый год работы, Lose[2] – за второй год и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
  цел t, m
целтаб Lose[1:10]
Lose[1] := 1; Lose[2] := 5
Lose[3] := 3; Lose[4] := 6
Lose[5] := 7; Lose[6] := 12
Lose[7] := 1; Lose[8] := 3
Lose[9] := 3; Lose[10] := 1
m := 0
нц для t от 1 до 10
если Lose[t] < 6 то
m := m + Lose[t]
все
кц
вывод m
Ответ: 
6. В таблице Dat хранятся данные измерений среднесуточной температуры в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
  целтаб Dat[1:7]
цел k, day
Dat[1] := 9; Dat[2] := 11
Dat[3] := 10; Dat[4] := 13
Dat[5] := 8; Dat[6] := 5
Dat[7] := 11
day := 0
нц для k от 1 до 7
ели Dat[k] <= 10 то
day := day + 1
все
кц
вывод day
Ответ: 
7. В таблице Dat хранятся данные измерений среднесуточной морской воды в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
  целтаб Dat[1:7]
цел k, day
Dat[1] := 19; Dat[2] := 21
Dat[3] := 20; Dat[4] := 23
Dat[5] := 24; Dat[6] := 25
Dat[7] := 23
day := Dat[1]
нц для k от 1 до 7
если Dat[k] > day то
day := Dat[k]
все
кц
вывод day
Ответ: 
8. В таблице Tur хранятся данные о количестве ребят, ходивших в поход вместе с туристическим клубом "Полянка". (Tur[l] - число ребят в 2001 году, Tur[2] - в 2002 году и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
  цел k, m
целтаб Tur[1:11]
Tur[1] := 1; Tur[2] := 11
Tur[3] := 8; Tur[4] := 12
Tur[5] := 5; Tur[6] := 6
Tur[7] := 15; Tur[8] := 16
Tur[9] := 16; Tur[10] := 21
Tur[11] := 7
m := 0
нц для k от 1 до 11
если Tur[k] < 10 то
m := m + Tur[k]
все
кц
вывод m
Ответ: 
9. В таблице Work хранятся данные о количестве заказов, принятых фирмой "Алоэ" с первого по 15 ноября. (Work[l] - число заказов, принятых 1 ноября, Work[2] - 2 ноября и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
  цел k, m
целтаб Work[1:15]
Work[1] := 5; Work [2] := 4
Work[3] := 5; Work [4] := 7
Work[5] := 6; Work [6] := 12
Work[7] := 7; Work [8] := 3
Work[9] := 9; Work [10] := 7
Work[11] := 0; Work [12] := 9
Work[13] := 1; Work [14] := 0
Work[15] := 8
m := 0
нц для k от 1 до 15
если Work [k] < 7 то
m := m + 1
все
кц
вывод m
Ответ: 
10. В таблице Sea хранятся данные о количестве россиян, отдыхавших на Чёрном море (Sea[l] - число россиян в 2001 году, Sea[2] - в 2002 и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
  цел k, s
целтаб Sea[1:12]
Sea[1] := 170; Sea [2] := 170
Sea [3] := 190; Sea [4] := 210
Sea [5] := 230; Sea [6] := 220
Sea [7] := 240; Sea [8] := 160
Sea [9] := 190; Sea [10] := 210
Sea [11] := 170; Sea [12] := 170
s := 100
нц для k от 1 до 12
если Sea [k] > 220 то
s := s + Sea [k]
все
кц
вывод s
Ответ: